Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 22:51 UTC
Update
We would like to update that after additional investigation, the impact would manifest in delayed and sometimes failed host jobs, which could include many different actions on Linodes and not only impacting attaching and detaching Block Storage volumes as we mentioned in our initial update, we have updated the title to reflect the updated impact. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Jul 28, 2026 - 20:17 UTC
Identified
Our team has identified the issue affecting the Block Storage service in our data centers. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Jul 28, 2026 - 19:27 UTC
Investigating
Our team is investigating an issue affecting the Block Storage service in several data center regions. This issue largely impacts attaching and detaching Block Storage volumes. During this time, users may experience volume attach/detach hangs, timeouts and errors with this service. We will share additional updates as we have more information.
Posted Jul 28, 2026 - 18:14 UTC
This incident affects: Block Storage (US-East (Newark) Block Storage, US-Central (Dallas) Block Storage, US-West (Fremont) Block Storage, US-Southeast (Atlanta) Block Storage, US-IAD (Washington) Block Storage, US-ORD (Chicago) Block Storage, CA-Central (Toronto) Block Storage, EU-West (London) Block Storage, EU-Central (Frankfurt) Block Storage, FR-PAR (Paris) Block Storage, AP-South (Singapore) Block Storage, AP-Northeast-2 (Tokyo 2) Block Storage, AP-West (Mumbai) Block Storage, AP-Southeast (Sydney) Block Storage, SE-STO (Stockholm) Block Storage, US-SEA (Seattle) Block Storage, JP-OSA (Osaka) Block Storage, IN-MAA (Chennai) Block Storage, BR-GRU (São Paulo) Block Storage, NL-AMS (Amsterdam) Block Storage, ES-MAD (Madrid) Block Storage, IT-MIL (Milan) Block Storage, US-MIA (Miami) Block Storage, ID-CGK (Jakarta) Block Storage, US-LAX (Los Angeles) Block Storage, GB-LON (London 2) Block Storage, AU-MEL (Melbourne) Block Storage, IN-BOM-2 (Mumbai 2) Block Storage, DE-FRA-2 (Frankfurt 2) Block Storage, SG-SIN-2 (Singapore 2) Block Storage, JP-TYO-3 (Tokyo 3) Block Storage).