Linode Status

Current Status

Service Issue - Linode Kubernetes Engine

Incident Report for Linode

Postmortem

On February 5, 2025, at approximately 21:38 UTC, DockerHub imposed rate limits on image pulls from our IPv6 IP space across multiple regions. This resulted in 429 Too Many Requests errors when making both unauthenticated and authenticated image pull requests over IPv6. As a consequence, several products, including LKE and LKE-E, as well as other services relying on DockerHub image pulls, were impacted.

The issue was traced back to DockerHub’s abuse prevention measures, which rate-limited traffic based on IPv6 address checks. DockerHub clarified that the failure occurred due to exceeding their abuse limit, which was triggered by how IPv6 checks the first 64 bits of an address. As an interim fix to get around this block, we’ve modified our DNS resolvers to return an 'A' record instead of an 'AAAA' record, ensuring image pull requests to DockerHub use IPv4 instead. This action successfully mitigated the issue at approximately 04:30 UTC on February 6, 2025. To prevent a recurrence of this issue, we are actively exploring long-term solutions that help ensure that our services are not impacted by DockerHub’s abuse prevention measures going forward. 

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Feb 28, 2025 - 19:01 UTC

Resolved

We haven’t observed any additional issues with the LKE and LKE-E services, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Feb 06, 2025 - 05:14 UTC

Monitoring

At this time we have been able to correct the issues affecting the LKE service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Feb 06, 2025 - 04:50 UTC

Update

We are continuing to work on a fix for this issue. We will provide the next update as we make progress.
Posted Feb 06, 2025 - 03:12 UTC

Identified

We have identified the issue affecting LKE, LKE-E, and other services, where image pull requests to DockerHub over IPv6 are being rate-limited. We are working on implementing a fix to resolve the rate limiting issue, and we will provide an update once the solution is in place. Thank you for your patience.
Posted Feb 06, 2025 - 01:06 UTC

Investigating

We are aware of an issue affecting DockerHub over IPv6, causing rate limiting between certain Linode data centers and DockerHub. This is impacting products like LKE, LKE-E, and other services that rely on image pulls from DockerHub repositories. We are actively investigating the issue, and will provide additional updates as more information becomes available.
Posted Feb 05, 2025 - 22:48 UTC
This incident affected: Linode Kubernetes Engine (US-ORD (Chicago) Linode Kubernetes Engine).