Linode Status

Current Status
Service Issue - Cloud Manager and API
Incident Report for Linode
Postmortem

Starting on January 20, 2025 at 15:49 UTC, we began to observe slowness, timeouts, and request failures when attempting to access the Cloud Manager and Linode API. Investigation revealed that it was caused by an error in a Bot Manager Premier script, which was making excessive calls to the API and causing a significant increase in load to our database. We mitigated the issue at 21:45 UTC by blocking traffic from the IP address on which the script was running.

To prevent recurrence of this issue, Akamai is implementing improved rate limiting and additional strategies for change safety.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Jan 30, 2025 - 19:11 UTC

Resolved
We haven't observed any additional issues with the Cloud Manager or API, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Jan 21, 2025 - 23:08 UTC
Monitoring
At this time we have been able to correct the issue affecting the Cloud Manager and API. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues and unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Jan 20, 2025 - 22:06 UTC
Investigating
Our team is investigating a service issue that affects the Linode Cloud Manager and API. During that time, some users may experience issues when attempting to access these systems. Specifically, we have observed slow responses, connection timeouts, and request failures. We will share additional updates as we have more information.
Posted Jan 20, 2025 - 19:20 UTC
This incident affected: Linode Manager and API.