Linode Status

Current Status

Service Issue - Linode Kubernetes Engine

Incident Report for Linode

Postmortem

Starting around 01:00 UTC on March 5, 2025, some customers began experiencing issues with multiple LKEs (Linode Kubernetes Engine) failing to autoscale when IP ACL was enabled, resulting in service disruptions. Approximately 20-25 clusters across various regions were affected globally. Akamai’s investigation traced the issue to the latest software release deployment. New nodes were unable to join LKEs with IP ACL enabled, preventing the autoscaler feature from functioning properly. As a temporary mitigation, Akamai restarted the gateway pods, but this provided only short-term relief. Further analysis identified the root cause as a software defect. To address the issue, Akamai rolled back the release. The rollback was completed around 15:00 UTC on all affected clusters, effectively resolving the problem. Akamai will continue to investigate the root cause and take appropriate preventive actions. We apologize for the impact and thank you for your patience and continued support.
This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Mar 12, 2025 - 02:46 UTC

Resolved

We haven’t observed any additional issues with the LKE service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 05, 2025 - 15:12 UTC

Monitoring

At this time we have been able to correct the issues affecting the LKE service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 05, 2025 - 08:58 UTC

Update

We are continuing to investigate this issue and will provide the next update as we make progress.
Posted Mar 05, 2025 - 07:46 UTC

Investigating

Our team is investigating an issue affecting the Linode Kubernetes Engine (LKE) related to auto-scaling when IP ACL is turned on. We will share additional updates as we have more information.
Posted Mar 05, 2025 - 06:49 UTC
This incident affected: Linode Kubernetes Engine (US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, US-SEA (Seattle) Linode Kubernetes Engine, IN-MAA (Chennai) Linode Kubernetes Engine).