Resolved
Our team deployed a fix and we haven’t observed any additional issues with the LKE service, and will now consider this incident resolved.
We do recommend recycling the new nodes that were created post 4:00 UTC today. If you continue to experience problems, please open a Support ticket for assistance.
Posted Nov 18, 2025 - 09:58 UTC
Update
Our team is deploying the patch fix that was determined previously. Further updates will be shared post deploying the fix.
Posted Nov 18, 2025 - 09:14 UTC
Identified
Our team has identified a patch fix that will correct the unexpected resource-limit behavior. We are currently reviewing the patch fix for release and deployment. Further updates will be shared as soon as more information is available.
Posted Nov 18, 2025 - 07:59 UTC
Investigating
Our team is investigating an emerging issue affecting certain workloads on Linode Kubernetes Engine (LKE). A recent platform update may be contributing to unexpected resource-limit behavior for some customer pods, potentially leading to degraded performance or connection-related errors.
We are actively assessing the impact and working toward a mitigation. Further updates will be shared as soon as more information is available.
Posted Nov 18, 2025 - 07:02 UTC
This incident affected: Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine, US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, FR-PAR (Paris) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine, SE-STO (Stockholm) Linode Kubernetes Engine, US-SEA (Seattle) Linode Kubernetes Engine, JP-OSA (Osaka) Linode Kubernetes Engine, IN-MAA (Chennai) Linode Kubernetes Engine, ID-CGK (Jakarta) Linode Kubernetes Engine, BR-GRU (São Paulo) Linode Kubernetes Engine, NL-AMS (Amsterdam) Linode Kubernetes Engine, ES-MAD (Madrid) Linode Kubernetes Engine, IT-MIL (Milan) Linode Kubernetes Engine, US-MIA (Miami) Linode Kubernetes Engine, US-LAX (Los Angeles) Linode Kubernetes Engine, GB-LON (London 2) Linode Kubernetes Engine, AU-MEL (Melbourne) Linode Kubernetes Engine, IN-BOM-2 (Mumbai 2) Linode Kubernetes Engine, DE-FRA-2 (Frankfurt 2) Linode Kubernetes Engine, SG-SIN-2 (Singapore 2) Linode Kubernetes Engine, JP-TYO-3 (Tokyo 3) Linode Kubernetes Engine).