Linode Status

Current Status

Service Issue - Linode Kubernetes Engine (LKE)

Incident Report for Linode

Update

We are continuing work to apply the identified fix the issue affecting the LKE and newly updated/created NodeBalancer configurations and we will provide an update as soon as the solution is in place.
Posted Apr 24, 2026 - 23:06 UTC

Update

We are continuing work to apply the identified fix the issue affecting the LKE and newly updated/created NodeBalancer configurations and we will provide an update as soon as the solution is in place.
Posted Apr 24, 2026 - 22:07 UTC

Update

Our team has identified the issue affecting the LKE and newly updated/created NodeBalancer configurations. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Apr 24, 2026 - 21:46 UTC

Update

Our team has identified that due to this issue, customers may also experience issues creating new nodebalancers. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Apr 24, 2026 - 20:48 UTC

Identified

Our team has identified the issue affecting the LKE service. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Apr 24, 2026 - 20:19 UTC

Investigating

Our team is investigating an emerging service issue affecting the Linode Kubernetes Engine (LKE) service across multiple regions. We will share additional updates as we have more information.
Posted Apr 24, 2026 - 19:27 UTC
This incident affects: NodeBalancers (US-East (Newark) NodeBalancers, US-Central (Dallas) NodeBalancers, US-West (Fremont) NodeBalancers, US-Southeast (Atlanta) NodeBalancers, US-IAD (Washington) NodeBalancers, US-ORD (Chicago) NodeBalancers, CA-Central (Toronto) NodeBalancers, EU-West (London) NodeBalancers, EU-Central (Frankfurt) NodeBalancers, FR-PAR (Paris) NodeBalancers, AP-South (Singapore) NodeBalancers, AP-Northeast-2 (Tokyo 2) NodeBalancers, AP-West (Mumbai) NodeBalancers, AP-Southeast (Sydney) NodeBalancers, SE-STO (Stockholm) NodeBalancers, US-SEA (Seattle) NodeBalancers, JP-OSA (Osaka) NodeBalancers, IN-MAA (Chennai) NodeBalancers, BR-GRU (São Paulo) NodeBalancers, NL-AMS (Amsterdam) NodeBalancers, ES-MAD (Madrid) NodeBalancers, IT-MIL (Milan) NodeBalancers, US-MIA (Miami) NodeBalancers, ID-CGK (Jakarta) NodeBalancers, US-LAX (Los Angeles) NodeBalancers, GB-LON (London 2) NodeBalancers, AU-MEL (Melbourne) NodeBalancers, IN-BOM-2 (Mumbai 2) NodeBalancers, DE-FRA-2 (Frankfurt 2) NodeBalancers, SG-SIN-2 (Singapore 2) NodeBalancers, JP-TYO-3 (Tokyo 3) NodeBalancers) and Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine, US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, FR-PAR (Paris) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine, SE-STO (Stockholm) Linode Kubernetes Engine, US-SEA (Seattle) Linode Kubernetes Engine, JP-OSA (Osaka) Linode Kubernetes Engine, IN-MAA (Chennai) Linode Kubernetes Engine, ID-CGK (Jakarta) Linode Kubernetes Engine, BR-GRU (São Paulo) Linode Kubernetes Engine, NL-AMS (Amsterdam) Linode Kubernetes Engine, ES-MAD (Madrid) Linode Kubernetes Engine, IT-MIL (Milan) Linode Kubernetes Engine, US-MIA (Miami) Linode Kubernetes Engine, US-LAX (Los Angeles) Linode Kubernetes Engine, GB-LON (London 2) Linode Kubernetes Engine, AU-MEL (Melbourne) Linode Kubernetes Engine, IN-BOM-2 (Mumbai 2) Linode Kubernetes Engine, DE-FRA-2 (Frankfurt 2) Linode Kubernetes Engine, SG-SIN-2 (Singapore 2) Linode Kubernetes Engine, JP-TYO-3 (Tokyo 3) Linode Kubernetes Engine).