Linode Status

Current Status

Service Issue - US-LAX (Los Angeles)

Incident Report for Linode

Postmortem

On June 20th, 2025, at approximately 10:40 UTC, we observed a sudden increase in alerts affecting the Los Angeles (US-LAX) Block Storage service. These alerts included service unavailability, elevated latency, increased HTTP 429 errors, and spikes in retry attempts. 

Upon investigation, we identified a storage drive that was not performing as expected. Although it did not show any obvious signs of failure through standard checks, it was handling data inefficiently and slowing down system operations. This underperformance contributed to the issues customers observed. 

We disabled the affected drive from service, and immediately observed stabilization across the system. No further slow operations were detected within the cluster, confirming that the issue had been mitigated.  

The incident was fully mitigated by approximately 14:34 UTC on June 20th, 2025. 

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Jun 23, 2025 - 12:04 UTC

Resolved

We haven’t observed any additional issues with the Block Storage service in US-LAX (Los Angeles), and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jun 20, 2025 - 16:23 UTC

Monitoring

The issue has been identified and a fix has been implemented. We are currently monitoring the situation to ensure stability and will continue to watch for any further issues. Thank you for your patience.
Posted Jun 20, 2025 - 14:59 UTC

Update

We’re actively investigating this issue and will share additional updates as they become available. We sincerely apologize for any impact this may have and truly appreciate your patience as we work to resolve it.
Posted Jun 20, 2025 - 14:37 UTC

Update

Our team is investigating a service issue affecting Block Storage in US-LAX (Los Angeles). We are still working to identify the cause, and we will provide an update as soon as we have more information.
Posted Jun 20, 2025 - 13:45 UTC

Investigating

Our team is investigating an emerging service issue affecting services US-LAX (Los Angeles). We will share additional updates as we have more information.
Posted Jun 20, 2025 - 12:38 UTC
This incident affected: Block Storage (US-LAX (Los Angeles) Block Storage).