Linode Status

Current Status

Service Issue - Linode Cloud Manager and API

Incident Report for Linode

Postmortem

Starting around 01:01 UTC on November 14, 2025, Compute customers were intermittently unable to access Linode Cloud Manager and operations involving the Linode API, including certain Linode Kubernetes Engine (LKE) operations like auto-scaling were failing. Akamai’s proactive monitoring system detected this issue, triggering the internal alerts.

During the preliminary investigation, Akamai observed failures in Linode's hosting database (DB). Further investigation determined that the issue was caused due to a high volume of concurrent connections and long-running queries in the primary DB. As part of the mitigation effort, we have manually killed the concurrent connections and long-running queries in the primary DB. Following these actions, the impact was mitigated at around 03:20 UTC on November 14, 2025.

We will continue to investigate the root cause and will take appropriate preventive actions. We apologize for the impact and thank you for your patience and continued support. If you need further assistance, please open a support ticket or call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Nov 17, 2025 - 10:34 UTC

Resolved

We haven't observed any additional issues with the Cloud Manager or API, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Nov 14, 2025 - 04:49 UTC

Monitoring

We have mitigated the issue affecting the Linode Cloud Manager and API. We will be monitoring this issue to ensure that the service remains stable. If you are still experiencing issues and unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Nov 14, 2025 - 03:51 UTC

Update

We are continuing to work on mitigating this issue. We have restored partial Cloud Manager and API functionality. Operations through the Linode Cloud Manager and API, including LKE operations like auto-scaling, may intermittently hang or fail until service has been fully restored. We will share additional updates as we have more information.
Posted Nov 14, 2025 - 03:16 UTC

Update

We have identified a service issue affecting the Linode Cloud Manager and API. While we work to resolve this issue, the Linode Cloud Manager and API may be intermittently unavailable across all regions, and operations through the Linode API, including certain Linode Kubernetes Engine (LKE) operations like auto-scaling, may fail.
Customers will be unable to open Akamai Cloud Support tickets while the Linode API remains unavailable. We are actively working to restore normal service and will provide additional updates as we make progress.
Posted Nov 14, 2025 - 02:17 UTC

Investigating

Our team is investigating an emerging service issue affecting the Linode API. We will share additional updates as we have more information.
Posted Nov 14, 2025 - 01:11 UTC
This incident affected: Linode Manager and API.