Linode Status

Current Status

Service Issue - Object Storage - Chicago

Incident Report for Linode

Postmortem

Around 04:14 UTC on December 19, 2025, Akamai identified an issue with one Object Storage system in Chicago that caused Lifecycle (LC) processing to fail. As a result, data was not deleted as expected, leading to data buildup and over-quota conditions for some customers.

 The investigation determined that a Ceph version mismatch was the root cause of the LC processing failures. The issue was resolved by performing the required upgrades, and the impact was mitigated by approximately 12:25 UTC on December 24, 2025.

To prevent recurrence, Akamai will review the actions taken as well as the relevant procedures and implement the necessary changes.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Jan 06, 2026 - 07:11 UTC

Resolved

We haven’t observed any additional issues with the Object Storage service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Dec 24, 2025 - 14:49 UTC

Monitoring

At this time we have been able to correct the issue affecting the Object Storage service in Chicago. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues and unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Dec 23, 2025 - 22:39 UTC

Identified

Our team has identified the issue affecting Object Storage in Chicago. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Dec 23, 2025 - 15:52 UTC

Update

We are continuing to investigate this issue. We will share additional updates as we have more information.
Posted Dec 23, 2025 - 11:21 UTC

Investigating

Our team is investigating an emerging service issue affecting Object Storage in Chicago. Specifically, we are investigating an issue that is preventing Lifecycle policies from being carried out as expected on the E1 endpoint (us-ord-1.linodeobjects.com). We will share additional updates as we have more information.
Posted Dec 22, 2025 - 20:27 UTC
This incident affected: Linode Manager and API and Object Storage (US-ORD (Chicago) Object Storage).