Linode Status

Current Status

Connectivity Issue - EU-West (London) datacenter

Incident Report for Linode

Resolved

We haven’t observed any additional connectivity issues in our EU-West (London) data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Feb 27, 2026 - 09:33 UTC

Investigating

Our team is investigating an emerging service issue affecting the connectivity in EU-West (London). We will share additional updates as we have more information.
Posted Feb 27, 2026 - 07:59 UTC
This incident affected: Regions (EU-West (London)).