Linode Status

Current Status

Service Issue - Cloud Manager and API

Incident Report for Linode

Postmortem

Beginning at 22:35 UTC on August 1st, 2023, an issue with Linode's backend database impacted performance of the Linode Cloud Manager, as well as the Linode API. This resulted in customers experiencing slow response times in accessing their accounts or being able to issue API calls. This did not impact performance of existing services.

At 22:40 UTC, our database administrators were made aware of the incident and began investigating immediately. A bug within the backend of the database was discovered and mitigated. At 22:47 UTC, our systems began to show signs of recovery, and we began to receive reports of an improvement in the situation. By 23:40 UTC, we were able to confirm that the database had returned to expected performance.

It was determined by our incident response team that an extended investigation would be launched to ensure stability of the service moving forward. After completing this initiative, the incident was considered resolved at 14:13 UTC on August 3rd, 2023.

To prevent recurrences of this issue, we have upgraded the backend of our database services. Since this was completed, we have not witnessed any further issues with the components affected here.

Posted Sep 27, 2023 - 19:52 UTC

Resolved

This incident has been resolved.
Posted Aug 03, 2023 - 14:13 UTC

Update

Our incident response team is continuing to investigate the root cause of the incident, which impacted Cloud Manager and API. As we've previously mentioned, services are working as intended.

Please open a Support ticket, email us at support@linode.com or give us a call at 855-454-6633 (+1-609-380-7100 Intl.) if you are encountering any issues with accessing your account.
Posted Aug 02, 2023 - 11:14 UTC

Update

We have not observed any further interruptions to the performance of the Cloud Manager or API at this time. Our incident response team is continuing to investigate the root cause of the activity, but services are working as intended.

Please open a Support ticket, email us at support@linode.com or give us a call at 855-454-6633 (+1-609-380-7100 Intl.) if you are encountering any issues with accessing your account.
Posted Aug 02, 2023 - 04:30 UTC

Monitoring

Our team has identified a problem with the database that supports the Cloud Manager and API. Service has returned to normal. We are working to determine the specific root cause. We we do not anticipate additional interruptions to the Cloud Manager and API. We will continue to monitor while we work on a permanent fix.
Posted Aug 01, 2023 - 23:40 UTC

Investigating

Our team is investigating a service issue affecting the Linode Cloud Manager and API. During this time, some users may experience issues when attempting to access these systems. We will share additional updates as we have more information.
Posted Aug 01, 2023 - 22:43 UTC
This incident affected: Linode Manager and API.