We have confirmed that our earlier mitigation step resolved the issue and haven’t observed any additional issues with our Hosted DNS Service, and will now consider this incident resolved. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Jun 24, 2025 - 19:17 UTC
Identified
Our team has identified a problematic server and removed it from service at ~16:53 UTC. We have received reports and internal testing shows that this mitigated the issue and are continuing work to ensure long term mitigation. We will provide additional updates as we have more information.
Posted Jun 24, 2025 - 18:26 UTC
Update
We are continuing to investigate this issue.
Posted Jun 24, 2025 - 17:37 UTC
Update
Our team is investigating an issue affecting our Hosted DNS Service in Northwest Europe beginning at approximately 7:55 UTC on June 24, 2025. During this time, users may experience an elevated rate of errors, including records not updating or resolving as expected. We will share additional updates as we have more information.
Posted Jun 24, 2025 - 17:35 UTC
Investigating
Our team is investigating an emerging service issue affecting DNS resolution through our nameservers. We will share additional updates as we have more information.