Support Phone Outage
Incident Report for Linode
Resolved
At this time we have been able to restore the Support phone line. Please feel free to give us a call if you have any questions or concerns.
Posted 2 months ago. Mar 10, 2017 - 20:19 UTC
Investigating
We are currently experiencing issues with the Support phone line. Our team is investigating this matter and we will provide an update as soon as the Support phone line has been restored.
Posted 2 months ago. Mar 10, 2017 - 16:25 UTC