Linode Status

Current Status

Service Issue - Cloud Manager and API

Incident Report for Linode

Postmortem

Beginning approximately mid-September, a risk of serious customer impact to the Linode API and Cloud Manager surfaced due to continued increases in traffic from unoptimized queries to the management database. This resource utilization increase did result in intermittent and brief periods of database connection rejections which resolved automatically. Akamai analyzed and optimized identified queries, moving queries to target read-only resources where possible. We also made firmware changes to database firmware during a scheduled maintenance on October 1, 2025, which was a step towards long-term stability of this system. Due to the efforts and actions taken to optimize load on this system, we have not seen any issues since October 7, 2025. 

To prevent this issue from occurring in the future, we have instituted and will continue to iterate on finer-grained monitoring and alerting to quickly ascertain which applications are causing additional unoptimized load. We have also instituted a more rigorous process to review and optimize traffic on an ongoing basis.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Oct 17, 2025 - 14:38 UTC

Resolved

We haven't observed any additional issues with the Cloud Manager or API, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Oct 16, 2025 - 16:06 UTC

Update

We have implemented a fix for this issue as of October 7, 2025. Based on current observations, the service is resuming normal operations. Customers and partners can find more details on the Akamai Community: https://community.akamai.com/customers/s/feed/0D5a700000cRKGoCAO

We will continue to monitor to ensure that the impact has been fully mitigated.
Posted Oct 15, 2025 - 17:12 UTC

Update

We have not seen issues since 7 October 2025 and are continuing to monitor further. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Oct 15, 2025 - 09:23 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 08, 2025 - 20:53 UTC

Monitoring

A database maintenance was performed and we are currently monitoring the results. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Oct 02, 2025 - 08:00 UTC

Update

We are continuing to investigate this issue.
Posted Oct 02, 2025 - 00:05 UTC

Investigating

Our team is investigating a service issue that intermittently triggers 5XX responses in the Cloud Manager (https://cloud.linode.com/) and API request failures for brief periods. We will share additional updates as we have more information.
Posted Oct 01, 2025 - 22:05 UTC
This incident affected: Linode Manager and API.