Linode Status

Current Status

Support Phone Outage

Incident Report for Linode

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 21:08 UTC

Identified

We are currently experiencing intermittent issues with our Support phone line. Our third party provider is being impacted by upstream issues and is working towards a resolution, until resolved calls to our support line may have quality/connection issues.

No other services or contact methods are impacted at this time, if you are having difficulty connecting to us over the phone and need assistance, you can open a Support ticket or send an email to support@linode.com.
Posted Oct 20, 2025 - 20:05 UTC