We have observed that our services have remained stable. We now consider this incident resolved.
Posted Jul 28, 2023 - 17:39 UTC
Update
Our administrators will continue to monitor the implemented solution, over several hours, to ensure that no further issues are encountered and normal operations continue uninterrupted.
Please open a Support ticket or give us a call at 855-454-6633 (+1-609-380-7100 Intl.) if you need immediate assistance.
Posted Jul 28, 2023 - 08:44 UTC
Monitoring
We have implemented a fix for the issue which was impacting our Support team. We have resumed normal operations at this time and will be addressing submitted cases in order of urgency. Our administrators are currently monitoring this fix to ensure that no further issues occur.
Please open a Support ticket or give us a call at 855-454-6633 (+1-609-380-7100 Intl.) if you need immediate assistance.
Posted Jul 28, 2023 - 06:22 UTC
Investigating
Our Support team is currently experiencing a temporary service issue which will prevent us from accessing customer information, including support tickets and emails. We are investigating the source of this issue and will resume service as soon as possible.
If you are experiencing any performance issues which require immediate attention, please call us at 855-454-6633 (+1-609-380-7100 Intl.).