Linode Status

Current Status

Service Issue - Managed Databases

Incident Report for Linode

Postmortem

At approximately 18:00 UTC on July 27th, 2023, we began to observe that new database cluster deployments were failing and initiated our Incident Response Procedure. At ~21:00 UTC, the reason for these failures was identified as a networking issue causing connections to time out to our service deployment infrastructure. By 23:30 UTC, a fix had been implemented and was confirmed to have resolved the issue after a brief monitoring period.

On July 28th at 11:30 UTC, we began to observe additional instances of clusters failing to provision. Our team reinitiated Incident Response Procedure, and published a new status page here. We determined that connection timeouts had resurfaced and further infrastructure adjustments were made to address the timeouts. A solution was deployed at 23:49 UTC, and we began to monitor cluster provisioning to ensure that the issue was resolved.

On July 30th, we confirmed that the provisioning of clusters had remained in a stable, functioning state, and the incident was considered fully resolved at 19:57 UTC.

In order to prevent this issue from happening in the future, we took steps to improve our service deployment infrastructure to make it more resilient to transient network issues.

Posted Sep 21, 2023 - 20:49 UTC

Resolved

We haven’t observed any additional issues with our Managed Database service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jul 28, 2023 - 03:24 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 27, 2023 - 22:25 UTC

Monitoring

A fix has been implemented for this issue and we have confirmed that Managed Databases are now being successfully provisioned. We will monitor this to ensure services remains functional. If you are experiencing any issues with the Managed Database service, please open a ticket with our Support Team.
Posted Jul 27, 2023 - 21:17 UTC

Investigating

Our team is investigating a service issue affecting the provisioning of Managed Databases. During this time, users may experience issues when attempting to use these systems.

We will share additional updates as we have more information.
Posted Jul 27, 2023 - 19:55 UTC
This incident affected: Managed Databases.